Back to overview
Resolved

Test incident

Jul 1, 2026 at 2:53pm UTC
Affected services
Web Platform

Resolved
Jul 3, 2026 at 2:54pm UTC

We did it guys! well done

Created
Jul 1, 2026 at 2:53pm UTC

I dunno, something happened that degraded the frontend